Compatibility:
SharePoint 2013 Foundation (SPF) and Server (SPS) SharePoint 2010 Foundation (SPF) and Server (SPS) Windows SharePoint Services (WSS) 3.0 / Microsoft Office SharePoint Server (MOSS) 2007
SPF & SPS 2013 • 2010 • 2007
User Voices
(Loading...)

FilterZen: Feedback Forum > Inaccurate Results when using any field on an Ad Hoc Dynamic filter

I have a large list with several custom columns that I want to search using a keyword and filter the list down to those items. I have setup an ad hoc dynamic filter using the Name field that defaults to any field >> contains >> [insert keyword]. There are no restrictions on what fields can be selected. When I enter a keyword in, the results returned are not accurate. It is like it is not searching the fileleafref field. If I change any field to Name, and enter my keyword, I receive additional values that were not in my original search. I need it to return the full set of values and truly be "any field contains [insert keyword]".

Please advise.

January 16, 2012 at 23:37 | Unregistered CommenterChristi

Can you email us the following:

- export of your FilterZen Web Part (via its web part menu / Export option)

- STP export of the Library (structure only, no data) via Library Settings / Save as Template

- some additional more specific description of that fileleafref issue... you want to do a "any field contains X, including the file name field". What exactly is the inaccuracy? Are documents returned correctly except those where only the file name contains X?

All of this ideally via email -- thanks!

January 18, 2012 at 17:11 | Registered CommenterROXORITY